Site Speed

As is painfully obvious to everyone who visits the site, we are really struggling with site speed. To put it mildly, it’s atrocious. I’ve heard from many of you about the issue and all of us working on the site have a crushing sense of urgency about getting this right. Unfortunately, it feels like we just exited the emergency room where we gained some sense of stability, but have a bit of a recovery and improvement process ahead. In other words, it could take another week to get the site speed back to a level that is acceptable to everyone. I feel really bad about this issue. It’s been a huge inconvenience for everyone, but I believe I have a competent team who can fix the problem. But it’s a pretty big problem.

Navigation Issues

We’re also continuing to deal with navigational issues, especially when a user is viewing a post with a GIF. We believe we can solve that one in the next couple of days.

Can We Go Back?

Some have asked why we don’t go back to the old site until these issues are resolved. We’ve discussed that option as a team, but I’ve decided to try to fix our current technical problems with the expectation that the short term pain will be worth the long term gain. That’s a pretty big gamble, but one I’m comfortable making. That might also be an indicator of how much — as an owner — I disliked the structure and setup of the old site.

Need Your Help

I’d really appreciate knowing what other bugs you’ve come across that need to be cleaned up… especially if you’ve noted it before and it still isn’t fixed. I know this is a pain to document in the comments (you can also contact me via email here), but it’s VERY helpful. Again, so sorry for this massive fuck up.

  • Patchy

    There’s a dead spider in one of the elevators in my building that I’d like to have someone clean up. It has been there for at least two days. Or leave it. Maybe it is a reminder to all other spiders to GTFO or die. ¯_(ツ)_/¯

  • almightybeard

    Yall will get it figured. Keep it up. So far so good. Growing pains expected

  • m4a4
    • HoodieDog

      Got your email too. Will respond tomorrow.

      • Patchy

        Don’t keep us in suspense! Did you respond to the email yet?!

        • HoodieDog

          Yes. It was about you. Can’t say more.

          • Patchy

            That’s cold, dude.

      • m4a4

        So, whatever you guys did is noticeably faster on my end.

        • HoodieDog

          Yeah, got load times cut in half. Now we need to do that again and we’ll be back to where we were before making the switch.

  • slayz

    mr. hoodie dog sir,

    i have another request regarding the side panel navigation thumbnail thingy.

    could you make it so that when we’re in the FRESH section, the navigation thumbnail is automatically selected to FRESH? it’s currently set to FRONT by default, each time we view a new post. it’s a bit confusing as we are made to believe that we’re in the FRONT section instead.

    thank you for reading.

    • HoodieDog

      Thanks. Got it. Will need to get with developer to see how that might work. Right now, the developer is working on making it load faster. It’s still too slow.

      In our current configuration, my fear is that your suggestion will be load intensive (not good). Give me some time to respond back.

      • slayz

        yes. sometimes the site is slow. especially if it’s loading gif. yesterday was very bad, but it’s better today. i trust you’re doing your best and we love you for it.

        i understand if you can’t change the navigation thumbnail. it’s just a suggestion. my only gripe is that i can’t tell whether i’m in the Fresh Section or the Front Section. previously, i used to look at the navigation thumbnails or the highlighted New or Vote labels to the right of the LOLsnaps logo. now, everything looks the same in either sections.

        again, no pressure. i’ve been coming here for ages and i’m gonna keep coming here for many years to come. we’ll stick with ya thru thick and thin.

        keep up the good work!

        • HoodieDog

          Hoping you see another good uptick in speed after some changes we made today. If it’s not noticeable to you, ping me back.

          • slayz

            Hoodie Sir:
            1. the speed is so much better. No noticeable lag for gifs either.

            2. navigation buttons on some posts are still buggy, for instance this one, http://lolsnaps.com/funny/2678029 and also this one http://lolsnaps.com/funny/2678013, where the Next button is greyed out even though it’s not the latest post.

            also http://lolsnaps.com/funny/2678100 and http://lolsnaps.com/funny/2678173

            3. i’m a nexter and i use chrome. All this while i’ve always pinned LOLsnaps to the last page i’ve visited so that i can continue from there on my next visit. But lately, i’m being directed to the main page each time i open my browser. so i have to browse in reverse now. i’m not sure whether it’s the browser or the site. please help.

            edit #1: http://lolsnaps.com/funny/2678013 seems to work fine now.

            edit #2: navigations in the New sections are still buggy. I found two posts, namely http://lolsnaps.com/funny/2678080 and http://lolsnaps.com/funny/2678126 which are listed in the New thumbnails, but cannot be accessed by clicking the navigation buttons from the previous post. And by clicking on any navigation buttons at the above posts will take you to a random post in the Front Page Section.

          • HoodieDog

            Really helpful de-bugging feedback. Thanks very much.

          • HoodieDog

            BTW, have spent a fair amount of time going through all of your items and believe we can fix them all. They are all caching and CDN-related (the servers we use around the world to serve our content). Some fine-tuning should solve these issues.

          • slayz

            that’s great news! i’m looking forward to a better browsing experience.

            i’ll keep an eye for more bugs to report, sir!

          • HoodieDog

            One more question. Is this navigation stuff happening when you’re logged into your LolSnaps account? Every time I have tried to replicate the issues you reported, I had to log out and use the site without being logged in. Logging in prevents your browsing from being cached by our servers.

          • slayz

            oh! i’ve not logged into LolSnaps as i’m not uploading any snaps. i’m only logged into Disqus. Is that the cause of my problems?

          • HoodieDog

            Go ahead and log in when you visit the site. That will take care of the problem. In the meantime, we’ll work on fixing it for non-logged in users too.

          • slayz

            thanks, hoodie!

          • slayz

            hoodie sir,
            1. my pinned tab now sticks to the last page i’ve visited, even when i’m not logged in to LolSnaps. Hurray!
            2. new bug discovered. the vote counter is at zero on some of the snaps in the Front Section. How is this possible? see http://lolsnaps.com/funny/2680301, http://lolsnaps.com/funny/2680297, http://lolsnaps.com/funny/2680317
            3. some snaps failed to load in full. see http://lolsnaps.com/funny/2680334, http://lolsnaps.com/funny/2680338, http://lolsnaps.com/funny/2680342

          • HoodieDog

            We had a pretty significant update last night and the voting mechanism went all wonky and deleted voting points for every single snap on the site. The vote counter should now be working. There might still a few with problems, but we’re okay with that.

            I checked the snaps not loading and they loaded for me.

          • slayz

            damnit! they weren’t loading just a while ago. and i refreshed the snaps a few times to make sure. oh well, maybe the internet is effin’ with me.

          • HoodieDog

            Are you logged in as an lolsnaps user? If not, try that and tell me if the same problem occurs.

          • HoodieDog

            I *think* we have most of the items on your list fixed. Logged in, or not. Ping me back if you run into problems. The technology behind speeding the site up versus serving up some navigation bugs is hard to get right, so we may still need to make some small adjustments.

  • Sullenman

    I’ve been here for years, I’m not going anywhere. Just keep doing your thing.

  • Would thoughts and prayers help?

    • http://meilidraw.com Stickers the Bum

      thats step 3 of debugging

  • akka69

    Hi here are isome ssues i noticed:
    1)on mobile and pc, i used to browse the snaps starting from the last and clicking on “prev”. After about 10/20 pages, the “prev” button becomes grey and can’t be clicked anymore
    2) on mobile and pc the default website page does no more seem pointing on the “last” snap. I can’t understand the logic behind it.
    3) on pc, the small widget on the right showing 10 pages, does not match by default the snap you’re currently seeing on the page. It doesn’t follow when you use “prev” more than 1à times.
    4) I can’t grasp the difference between “front” and “last” on this widget
    5) When you use the widget to go back on another 10 snaps an then click on one small imagein the middle, you loose the widget context.

    • HoodieDog

      We’ve been working on some other enhancements and bugs and will now begin working on some these you point out. Thanks for your patience. Good stuff.

  • juggernaut

    Hi, also noticed when you use the previous button on the thumbs to go to another set of pictures, after you click on a picture, the thumbs reset to the most recent list, therefore losing my position and having to flick back each time to the last thumb I was viewing. Thanks.

    • HoodieDog

      Ah, that’s a good catch. Give us a little while to figure out how to get the sidebar not to refresh.

      • juggernaut

        Appreciate all the hard work you guys are doing!!

      • The009

        You could make the a dynamic load with an ajax style load off the menu. That would allow you to use something like handlebars ( sorry have not really dug into what you have changed ) or JQuery or any combination to dynamically update the content and menu sections of the page and not have to refresh the entire page.

        This would bring down a lot of load on the site as well allow for a more fluid style change of menus and content.

        ( I have not tried it with discuss plugins attached but I am sure it could be done quite easily with something like JQuery, Handlebars, and a lil bit of json )

  • AcidMan

    I can’t leave lolsnaps. The speed issue is the biggest annoyance for me, but it’s all good, ain’t going nowhere else.

    • HoodieDog

      Hoping some changes we recently made are increasing the speed on your end.

  • Tanya Wicht

    The only thing going slow for me, is the up/down vote thingy, sometimes it just keeps circling, not actually changing the number. But mostly it works well.

    • HoodieDog

      This *should* be noticeably faster.

      • Tanya Wicht

        It is definitely working well now, thanks 🙂

  • Fokke
  • AcidMan
    • Tim

      I thought this was resolved, but it happened again just now.
      http://lolsnaps.com/funny/2676864

      • HoodieDog

        Keeping coming back to this comment if it happens again. We’ve made some changes that we hope will solve the problem, but really appreciate hearing from you if the problem persists.

        • Tim

          No comments section on this page for me:
          http://lolsnaps.com/funny/2678478

          • HoodieDog

            We’ve been trying to tune our Disqus settings, but can’t seem to get it quite right. Going to try something a little more dramatic on Monday or Tuesday to see if we can get it to work ALL the time.

          • Tim

            Sounds good. Thanks!
            Also, random question: Am I missing the source button somewhere, or is that gone now?

          • HoodieDog

            It’s still then in the rare instance it’s included. It’s directly below the snap and will usually say CREDIT in the smallest font known to mankind.

            Also, I *think* we got the Disqus issue fixed. Holler at me if it happens to you again.

          • Tim
        • Tim
  • Kelvin

    Thanks for the update, Hoodie!
    I’ve grown to like the new site and its new layout and functions.

    Sometimes in single page view loading the page takes a bit long, as is known. the scroll works pretty flawless though.
    Not being able to use the hotkeys when there’s a gif is one of the things I encounter a lot. I hope in the future we will be able to start a gif-loop with a hotkey, that would be awesome.

    Your hard work is being appreciated. Keep it up!

  • AfterMath

    I know I have offered to help in this in any way I can, but we started a new project and i’ve been so busy lately trying to finish on time, anyway, i have an insight i’d like to share, i’ll send it to your inbox, and i promise i’ll be back to help as soon as i deliver my work, best of luck 😀

  • HoodieDog

    Hey, anyone having trouble getting the GIFs to play? Are they not playing at all? If so, chime in and give us some details. Trying to identify if this is a bug.

    • almightybeard

      If you scroll past the gif it stops and when going back up to it you have to hit the gif circle multiple times to make it play again or refresh the page

      • HoodieDog

        Checking in to see if you still have to hit the gif circle multiple times.

        • almightybeard

          Seems to be functioning properly now

          • almightybeard

            Also load times are much much better

  • Rev. Analbumcover

    Have you tried the turbo button?

    • Das Puggy

      There’s the problem. Turbo lag.

  • James

    Every now and then it still skips a snap or two when I hit previous. I’ve been coming here for like 6 years or something. I think I can handle the site loading slowly while it gets worked out. lol Keep up the great work!!

  • Slopok77

    I view Lolsnaps on an iPad and when I scroll to a GIF the GIF dot disappears and I have to tap the pic to get it back then I have to tap the dot 2 or 3 times before it plays.
    Speaking of scrolling, I think it would be great if front page scrolling would be the default when going onto Lolsnaps.

    • HoodieDog

      Wanted to check back to see if this is still occurring. We’ve updated things on our end to see if we can get things to smooth out a bit.

      • Slopok77

        Shortly after I posted I noticed the GIF dot only disappeared occasionally and lately I haven’t noticed it disappearing at all. Good job.

      • Slopok77

        2 days ago I said that the GIF dot problem was better, well now it’s like it was in my first post only slower. And now I cannot get the Front Page Scroll to work. When I select it it always brings me back to a meme I had viewed over a week ago and not the most recent. I’ve been viewing your sight for probably a year now. Lolsnaps and webfail.com are my everyday go to sites but Lolsnaps is getting just so painfully slow and nonfunctional that I have to remove it from my morning/evening rituals. Check out Webfail.com if you want to see how a site like yours should work. I’ll check back in occasionally to see if things get better. I hope to have you back soon, but for now I just can’t endure.

  • RaddClaw

    I still find it strange that I can’t see GIF’s on Chrome, I have to open the site on Firefox and refresh a couple of times… other than that, everything’s cool man 🙂 …like @disqus_MzWQIPhs6y:disqus says, we really appreciate what you do 🙂

    • HoodieDog

      Still giving you problems? Have made a few changes we’re hoping smoothes this stuff out.

      • RaddClaw

        It did… now I can see GIF’s on Chrome, definitely a huge improvement 🙂 thanks Hoodie

  • The009

    So as with GIF not loading right this one in single view is one that will not autoload for me.

    http://lolsnaps.com/funny/2675363

    It seems random the ones that do and don’t but this one no matter the way of load (Using FF57) it dose not autostart.

    • HoodieDog

      Just checking to see if some of the changes we’ve made have helped load gifs more consistently.

  • Daniel Emberton

    it seems to be going a lot better today…

  • Kirikoğlu Necmettin

    Hi. I was using keyword buttons to get to previous or next lolsnaps. Now i can’t. Tried both chrome and safari to see if my browser was the problem but no. I still love lolsnaps but i’m on hold now. Please make it work again. Keep up the good work.

    • HoodieDog

      Yeah, we’re working on it. Right now the ‘hotkeys’ don’t work unless you’re logged in. Not supposed to be that way.

    • HoodieDog

      This should be fixed. Ping me if not.

      • Kirikoğlu Necmettin

        It works great again. Thanks. 😉

  • OzzieSteve

    My favourite was the RANDOM button. Where has that gone?

  • Benjamin Banks

    Hoodie, you guys have made incredible strides in the last two days. Three days ago, i was pulling my hair out just getting through. Yesterday speeds were so much better. Today gifs seem to be loading just fine and do not seem to take a random 1-3 taps to get working. Nice job!

    • Benjamin Banks

      I am going to roll back just a bit on the gifs. I ran into a few gifs today where the gif icon button was playing hide and seek with me. Not sure if it is the way one scrolls or what. Annoying but not as annoying as the speed issues in the very recent past (esp the combination).

      • HoodieDog

        Had another significant uptick in speed today. Let me know how gifs are working for you. They’ve been incredibly inconsistent from user to user and browser to browser.

        • Benjamin Banks

          Hate to say it but I honestly do not see any real difference in the gifs. Still slow and inconsistent. If anything, the whole site seems slower this morning. Chrome on android mobile.

          • Diana Small

            same. chrome on droid.. gif is irritating.

          • HoodieDog

            Probably going to have to perform open heart surgery on our MP4 player. If I were to guess, we’re probably a week out from have an acceptable solution in place.

          • Benjamin Banks

            Sorry to hear that is necessary but I am sure it would be appreciated.

  • TotallyNotPax

    Hey Hoodie, trying to register on the website with the name TotallyNotPax but whenever I type in the N, it takes me to new posts. I got some posts I want to upload ( ͡° ͜ʖ ͡°)
    Also, the site has been running a bit faster, keep up the good work.

    • HoodieDog

      Hmmm… is this still problem?

      • TotallyNotPax

        I got it, I had to be on the blog page to stop it from happening though

  • Tony Alcock

    I no

  • Baba O’Buzzi Shalala

    what’s the problem then? is your IT crappy at their job?

    • HoodieDog

      No, but some of our users can be cranky.

  • Inaba

    the url broke overnight and i thought you went under

    • HoodieDog

      Well that escalated quickly.

  • Diana Small

    I’m just glad it’s a known issue & you’re working on it.

  • Tim

    Hi, again.
    I’m having issues getting the home page to load properly. It keeps loading the picture linked here as the first one on my laptop. My cell phone seems to be doing better at showing me the actual newest front page pictures.
    http://lolsnaps.com/funny/2677975

    • HoodieDog

      This should be fixed. You may need to clear your browser cache.

      • Tim

        That worked; thanks!

  • Al Do

    Hi Hoodie, noticed front page scroll is not updating to current pages.

    • HoodieDog

      Got it. Caching is messing it up. We’ll see if we can get it to cycle through.

      • Al Do

        Working fine now. ta.

    • HoodieDog

      Try a hard refresh on your browser to clear it. We’ll continue to work on the source of the problem, but this fixes it in our tests.

  • slayz

    Hoodie Sir,

    I can’t click next (the Next Button is grayed out even though it’s not the latest post). https://uploads.disquscdn.com/images/fa7ebb0cb3827896c022b250780b30aa34b0af5226f2dbb31f98b9e5009ef8c7.png

  • m4a4

    @HoodieDog:disqus Concerning the “previous button bug” for the front page, I am getting this. Both the previous and next links are messed up (and maybe the inspector view can help if you don’t already know why).

    https://uploads.disquscdn.com/images/4908d4094b3979673f2315c30fc773d4100811b602da0b42da6107ce91b5f040.png

    • HoodieDog

      A response I sent another user:

      We get reports from users about buggy navigation issues, but they clear themselves up before we can replicate them. That tells us it’s a caching issue that gets straightened up with the cache is flushed… which is about every 5 minutes.

      We’ll be pushing a fairly significant update to the site to correct the voting issue and several other bugs… hoping to do that today or tomorrow.

      • m4a4

        Ok. I got the issue a few times yesterday (so I figured I’d try to help). I’ll let you know if I come across it later after the update (provided it’s obvious enough that I notice lol)

Choose A Format
Image
Photo or GIF
Gif
GIF format
Video
Youtube, Vimeo or Vine Embeds